Classic Client not retaining Memorized Macros ?

poppspopps Posts: 1,683
Classic Client.

I have been trying to create some Macros using the Numeric Pad of the keyboard (in the Options --> Macro Options it indicates them with a "tn" code....) but, even if I click APPLY and then OK, it does not save them upon logging off the Character....

I mean, once I create them they are fine, they work and I can use them.

But as soon as I log off, they get lost and I need to redo them at each log in, over and over and over again....

Anyone knows if and what I am doing wrong and why they are not saved for my Character ?

Thanks !

Comments

  • MariahMariah Posts: 1,268Moderator
    This is a long known problem relating to different country's keyboard assignments. Here is some rather old information on the topic.

    Mapping to Keypad Numbers

    It is possible to map macros to the keypad numbers, however to do so you must turn off ‘Num Lock’. In addition you need to check that the keynames.txt file uses the same description for the keys. To do this, first record a test macro through the paperdoll in game, with Num Lock off. Next open the character’s macro2d.txt file in notepad and find the macro:

    ########

    NUM 1 1 1 0

    +S a y t h i s i s a t e s t

    In this example the key used is ctrl – Alt – NUM 1 (note the recorded entry in the macro2d.txt file generated the number as NUM – all caps.)
    The formatting of this can vary depending on the operating system or the keyboard’s ‘country’ settings. Alternatives are Num or num.
    Now find the keynames.txt file in the C:\Program Files\EA Games\Ultima Online 2D Client\ folder. Open this file in notepad and scroll down to the numbers.

    This file must have exactly the same name for the keys as that generated in the macros2d.txt file. If they are different, edit this file to match the macros2d.txt file. If the case formatting in the keynames.txt file does not match that generated in the macros2d.txt file, when recording a macro through the paperdoll, the macro will not save.
    To simplify: If macros2d.txt shows NUM 1 then keynames.txt must show NUM 1. If macros2d.txt shows Num 1, then keynames.txt must show Num 1. etc.


  • MervynMervyn Posts: 2,208
    The keynames file issue was fixed. Turning the numlock off as you also directed should solve this issue.
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • poppspopps Posts: 1,683
    edited September 19
    Question.

    To my knowledge, if I turn the NUMLOCK OFF then the keys won't work....

    At least, this is what happens when I am typing numbers from the numlock.... when it is off, the number do not show up where I am typing...

    So, if I am turning it OFF to make UO macros in the Classic Client, how can the Client then register my key stroke?
  • MervynMervyn Posts: 2,208
    edited September 19
    this is not really a uo-related question, however i'll answer it.

    the number pad keys are themselves seperate keys, by turning on the numlock, you're converting their functionality to instead work as inputting numbers, similar to how capslock works. Yes the keys will work with numlock off. And they'll stop working as macros with numlock on.
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • poppspopps Posts: 1,683
    Mariah said:
    This is a long known problem relating to different country's keyboard assignments. Here is some rather old information on the topic.

    Mapping to Keypad Numbers

    It is possible to map macros to the keypad numbers, however to do so you must turn off ‘Num Lock’. In addition you need to check that the keynames.txt file uses the same description for the keys. To do this, first record a test macro through the paperdoll in game, with Num Lock off. Next open the character’s macro2d.txt file in notepad and find the macro:

    ########

    NUM 1 1 1 0

    +S a y t h i s i s a t e s t

    In this example the key used is ctrl – Alt – NUM 1 (note the recorded entry in the macro2d.txt file generated the number as NUM – all caps.)
    The formatting of this can vary depending on the operating system or the keyboard’s ‘country’ settings. Alternatives are Num or num.
    Now find the keynames.txt file in the C:\Program Files\EA Games\Ultima Online 2D Client\ folder. Open this file in notepad and scroll down to the numbers.

    This file must have exactly the same name for the keys as that generated in the macros2d.txt file. If they are different, edit this file to match the macros2d.txt file. If the case formatting in the keynames.txt file does not match that generated in the macros2d.txt file, when recording a macro through the paperdoll, the macro will not save.
    To simplify: If macros2d.txt shows NUM 1 then keynames.txt must show NUM 1. If macros2d.txt shows Num 1, then keynames.txt must show Num 1. etc.


    "Alternatives are Num or num"
     @Mariah

    I guess that then I could have a problem as I did the Test Macro as you suggested, and opened in Notepad the macros2d.txt for that character on the Shard and the Test Macro was neither registered as Num nor num .... but, rather, as (Tn) 0 0 0

    I then searched for the keynames.txt file, opened it in the Notepad, but it shows the following I guess for the numeric pad

    Num 7
    Num 8
    Num 9
    Num -
    Num 4
    Num 5
    Num 6
    Num +
    Num 1
    Num 2
    Num 3
    Num 0
    Num Del

    Does that mean that I need to then Edit the keynames.txt file changing Num into Tn ??

    I would not want to mess something up by mistake....

  • MervynMervyn Posts: 2,208
    edited September 19
    that sounds like it actually is a keynames file issue then, just make sure what it says in keynames matches exactly what is says in uo. Just out of interest, what regional language setting is your keyboard set as? Is it English US, or something foreign?


    Also, trying it i'm sure would have been a lot less effort than typing out that whole paragraph.
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • poppspopps Posts: 1,683
    edited September 19
    Mervyn said:
    that sounds like it actually is a keynames file issue then, just make sure what it says in keynames matches exactly what is says in uo. Just out of interest, what regional language setting is your keyboard set as? Is it English US, or something foreign?


    Also, trying it i'm sure would have been a lot less effort than typing out that whole paragraph.
    According to this post here https://forum.uo.com/discussion/comment/43672/#Comment_43672 , my understanding is that the not saving of Numeric Pad keys Macros in Ultima Online Classic Client might not have to do with regional language (mine is English US).

    From that link above : 
    I grew very sick and quickly of the constant "change your keyboard to US layout" comments. Especially since that is my native keyboard & the fact that it had nothing to do with most peoples issues.
    This other post here https://forum.uo.com/discussion/comment/43664/#Comment_43664 , also, seems to get me understand that having the English [US] regional setting still might not help with having Numeric Pad keys Macros get saved upon log out.....

  • MervynMervyn Posts: 2,208
    Let us know if renaming the keynames file keys solved your issue,
    reason I am surprised is, there was a patchnote a long time ago saying they resolved the issue. Also I used to suffer from this issue and every time I did a full file check, I had to redo this file. This is no longer the case for me.
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • MariahMariah Posts: 1,268Moderator
    what number pad key did you actually use?
  • poppspopps Posts: 1,683
    edited September 20
    Mervyn said:
    Let us know if renaming the keynames file keys solved your issue,
    reason I am surprised is, there was a patchnote a long time ago saying they resolved the issue. Also I used to suffer from this issue and every time I did a full file check, I had to redo this file. This is no longer the case for me.
    It seemed to solve the issue but only very shortly.

    I mean, I logged off, and then back in and the macros would still work.

    Then I closed the client entirely and then relaunched it and still the keys seemed to be working.

    But then, I logged off for the day, closed the UO client for good and turned off the computer.

    When I restarted Ultima Online the following day, all of the Macros using the Numeric Pad where gone....

    It is really weird.... it is as if there was some evil genie inside of my computer "specifically" targeting those macros using the Numeric Pad keys and deleting only those Macros using Numeric Pad keys from the macro2d.txt file.... all of the other Macros not using Numeric Pad keys remain untouched and working inside of the macro2d.txt file.... they get not deleted...

    I have been trying to find some logic reasoning of "what" could make those macros, and only those, get deleted from the macro2d.txt file but could not fine one... my suspect, is that some sort of a conflict might exist with some file checker within the Ultima Online Client which ends up having the Client delete from the macro2d.txt file ONLY the Macros that are using the Numeric Pad keys...

    Is that a reasonable possibility @Bleak and @Kyronix ?

    As of now, what I do is, I saved a backup version on the macro2d.txt file which contains those Numeric Pad keys' Macros and, before I launch the UO Client, I just add them again from the backup file to the macro2d.txt file that got them deleted, somehow, and when I launch for that day the UO Client I have the Numeric Pad keys' Macros usable again....

    It is definitively not a permanent solution, and I would LOVE this issue to get fixed for good but, at least, as of now, I do not have to rebuild those Macros one by one every new day that I am going to play some UO... I just use a backup macro2d.txt file carrying them and replace the one which had, somehow, those Macro be deleted by the Client....

    Damn annoying, that is sure, and it beats me how this issue persist in Ultima Online some 23 Years after its creation (how is it possible that in 23 Years this rather important issue was not fixed for good ??), but at least, by saving a backup file, I was able to tone done the annoyance a little bit..., but still annoying like hell..... 
    Mariah said:
    what number pad key did you actually use?
    I am actually using all of them....well, most, all the Numeric Pad numbers from 1 to 9 as well as the + (plus) and the - (minus) keys.... Twice, since 11 Macros are plain (no CTRL nor SHIFT nor ALT) and another 11 Macros are still those Numeric Pad keys plus CTRL.

     
  • MervynMervyn Posts: 2,208
    edited September 20
    may i ask, when you launch the uo patcher, do you have ticked the full file check? if so, you will need to uncheck this.

    If it's already unticked, you may need to launch uo by launching client.exe from the uo directory (this launches uo and skips the patcher which is rewriting the keynames file), and unfortunately you will have to replace the keynames file after every patch.

    I'm not sure why this issue has returned for you.
    Has it only just started doing this or did you recently only just decide to save macros to the numberpad?
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • MariahMariah Posts: 1,268Moderator
    What is confusing me is the (Tn) code. I don't use CC now, but I have checked making such a macro in it, and my pc doesn't use that, it uses the same protocol as is listed in the info I copy/pasted in my previous post.
  • poppspopps Posts: 1,683
    Mervyn said:
    may i ask, when you launch the uo patcher, do you have ticked the full file check? if so, you will need to uncheck this.

    If it's already unticked, you may need to launch uo by launching client.exe from the uo directory (this launches uo and skips the patcher which is rewriting the keynames file), and unfortunately you will have to replace the keynames file after every patch.

    I'm not sure why this issue has returned for you.
    Has it only just started doing this or did you recently only just decide to save macros to the numberpad?
    I launched the UO Classic Client and the "Perform full file Check" was unchecked. I do not pay attention to it when I start UO so, I need to assume that also in the past it was unchecked as it is now. Not sure if a patch does an automatic file check regardless of the setting of this box, though.

    I now have checked the Perform full file Check box, and the UO Classic Client has performed a full file check, unfortunately, upon getting in the game, all of my Numeric Pad Keys Macros have gone, I checked the  macro2d.txt file and they are gone, nowhere to be seen....

    Not sure though, if it has been my checking the "Perform full file Check" box because, as I said, it was unchecked when I looked at it so, I must assume that also in the past days where I still have my Numeric Pad keys Macros deletec from the  macro2d.txt file, this box was unchecked.

    So, I do not know whether this is what erases my macros....

    I had to restore my macro2d.txt back up file containing the Numeric Pad keys Macros in order to be able to use them, as I have been doing now every time I can play UO.

    It is a work around, not as bad as having to redo each single macro manually when I play UO but, I still would way much more prefer not to have this annoyance althougether...
  • poppspopps Posts: 1,683
    Mariah said:
    What is confusing me is the (Tn) code. I don't use CC now, but I have checked making such a macro in it, and my pc doesn't use that, it uses the same protocol as is listed in the info I copy/pasted in my previous post.
    I have no idea what to tell you, my computer knowledge is very limited so, I have no idea.

    All I know, is that it looks like I got some Genie inside my computer who, in spite of me, enjoys deleting my Numeric Pad keys Macros from my Ultima Online macro2d.txt file, and those Macros only, so that I have to redo them each time I want to play UO....

    Of course that there has to be a logical explaination for this, I just can't figure out what is causing this. I wished it did not happen though, as it sure is annoying to have to restore my macro2d.txt file each time that I want to play UO....
  • MervynMervyn Posts: 2,208
    edited September 21
    Do you per chance have an Italian keyboard?
    i am also unable to diagnose the issue as you’ve stated your keyboard language is set to English US.
    I tell you the truth, tis better to do 10 damage on the right target than 100 damage on the wrong target.

    Breaking in the young since 2002


  • poppspopps Posts: 1,683
    edited September 21
    Mervyn said:
    Do you per chance have an Italian keyboard?
    i am also unable to diagnose the issue as you’ve stated your keyboard language is set to English US.
    Nope, set to English (US) as I mentioned.

    I have checked again the macro2d.txt file and it says Num for those Macros, also checked again the keynames.txt file and it also says Num (not NUM) so, the 2 files match the definition and yet, I get them deleted nonetheless, I have no clue....

    As I said, they may stay up for a few client sessions but eventually, "something" happens that gets those Macros, and only those Macros get deleted from the macro2d.txt file and I need to restore my backup file of it....

    My guess, is that some internal check for the UO Client for some reasons does not like those Macros and wipes them out.... what check would it be, I got no idea....
Sign In or Register to comment.