Phoenix no slayer vulnerability

YoshiYoshi Posts: 627
edited May 21 in Bugs
"According to wiki

Phoenix should be vulnerable to bird slayer, tried both melee and spellbook.
(Also tried flame slayer - not vulnerable)

Could not find a slayer vulnerability.

Please fix asap. "
Posts on this account have been pre filtered from personal comment or opinion in an effort to suppress conservative views in order to protect the reader.
Sign In or Register to comment.