Regarding the problem with the enhanced client not starting.

LureLure Posts: 6
edited July 2020 in Bugs
We are using a Ryzen9 3950X.
It has 16 cores and 32 threads.

In Winsows 10 Safe Mode, UOSA starts up when I limit the number of cores in the CPU.

When using System Explorer, UOSA does not start up even if the number of cores to be allocated is limited.

1. 32 cores in safe mode (with network)

  The UOSA.exe window does not open.

2. 31 cores in safe mode (with network)

  UOSA.exe starts up normally.

3. Normal startup  32 cores

  The UOSA.exe window does not open.

4. Normal startup  31 cores

  UOSA.exe starts up normally.

We use msconfig to limit the number of cores.
The classic client will start up normally with 32 cores.

Is there anything that can be done by users?

The classic client starts up fine.



  • maydaymayday Posts: 1
    edited July 2020

    I was able to reproduce this same issue on Windows 10.  I also have a 3950x and while the initial Patch Client would load, the window would just disappear after clicking Play.

    Its rather undesirable to have to limit the CPU cores in msconfig.  Another method is to start the game client UOSA.exe with processor affinity to use 31 threads. In a Command Prompt cd to your Ultima Online install directory and run the following:
    cd "c:\Program Files (x86)\Electronic Arts\Ultima Online Enhanced"
    start /affinity 7FFFFFFF UOSA.exe

    Ultimately I found the best workaround was to set Windows 98 compatibility mode on UOSA.exe.  (Windows 95 and 98 compatibility seem to work fine, XP and higher do not.)

    My guess is there is an issue with the game client code and the Windows CPU scheduler on systems with 32 threads.

    I hope this helps.

  • LureLure Posts: 6
    Thank you Leslie.
    As mayday said, I tried it in compatibility mode (98) and it worked.
    Thank you very much.
Sign In or Register to comment.