Classic Client Targeting System

MerusMerus Posts: 298
I am experiencing two new issues with the classic client targeting macro.

First issue is that even when surrounded by hostile mobs doing damage to me I get the message "there are no hostiles on screen to target".  I would say that my macro works @ 80% of the time, but 20% I receive the no hostiles message.

Second issue is that Rising Colossus, Energy Vortex, and other non-hostile mobiles seem to be pulling up as a hostile when they are clearly not hostile to me.

Classic Client macro is very simple: 
Action:
Box 1: Select nearest  Box 2: Hostile


Clearly this hart is not hostile to me (it is full life and walking away).




Multiple hostiles on the screen and taking damage (indicated by the yellow damage numbers coming off my character and the lightning bolt hitting me) yet I get the message no hostiles to select (3rd message line from the bottom).


@Kyronix @Bleak 

Targeting systems are pretty core to any games functionality and this issue should be addressed.

Thanks.

Comments

  • No hostiles on screen is a problem for a bit now.
    Andsometimes, instead of hitting the nearest one, it target one almost offscreen...go figure

    Targetting the deer doesnt bother me, it is a grey, so its fair game

    Summons shouldn't be targetted unless the summoner is grey to us.  Would be a nice fix to have that done.
  • PawainPawain Posts: 2,737
    If it would just target any type of hostile or grey that is close enough for you to hit when you are in a crowd, I would be fine.  Right now it does not do that reliably.

  • MerusMerus Posts: 298
    I can’t believe that a system as core as targeting isn’t getting some priority to be addressed.
  • TimStTimSt Posts: 1,013
    Energy Vortex hates animals.  It goes after birds, cats, dogs, rabbits, horses, cows, hogs, etc.
  • MerusMerus Posts: 298
    TimSt said:
    Energy Vortex hates animals.  It goes after birds, cats, dogs, rabbits, horses, cows, hogs, etc.
    I'm not sure how that is relevant?
  • MerusMerus Posts: 298
    @Bleak @Kyronix @Mesanna

    Any acknowledge on this?
  • MerusMerus Posts: 298
    edited December 2019
    Giving this a bump for @Bleak since we discussed at the Sonoma M&G.

    I suggested it might be related to a z axis issue for either uneven terrain or mobs standing on top of other mob corpses that could be to blame... but just a guess.
  • FenFen Posts: 15
    Sorry I didn't see this post before I added mine..same issue. 

    I think TimSt's issue relates to the EV's and RC's running off after animals instead of just hostiles (i.e. monsters). I find that particularly annoying when treasure hunting.  It would be nice if all these "hostile" issues could be fixed!!
Sign In or Register to comment.