problem using Archery Mastery skills

RockRock Posts: 373
edited August 2018 in Skills and Stats
There is apparently something I do not understand when using my level II archery mastery abilities.  I have two available masteries, Peacemaking level III and Archery level II.  The two Peacemaking masteries function as expected. But when I select Archery, I see the passive skill Warrior's Gifts active in my EC buff tray.  However when I try to activate either Playing the Odds or Flaming Shot, they fail.  A message appears in my text window, "You do not have that spell!".  Their icons have been dragged to my hotbar, and I attempt to activate them from there.

I have tried them in and out of war mode and in and out of battle.  They always fail.  What am I doing wrong?
Rock (formerly Imperterritus VXt, Baja)

Comments

  • RockRock Posts: 373
    Problem solved.  Rock's Book of Mastery's was probably acquired in 2010 via the Peacemaking quest, not Hawkwind's quest. (Hawkwind, non-bardic masteries, and the new land didn't even exist.)   Hovering over the book reported 6 spells, I'm guessing the 6-bard related mastery spells.  It would let me switch to Archery, but except for the passive, it didn't actual contain the active spells.

    So Rock redid the bard quest, calmed his 5 mongbats, and got a new book.  Hovering over this book reports 45 spells, and I can activate all the Archery abilities. ("peace 5 mongbats" vs Hawkwind's "defeat strong boss".  Seems to be a disparity in book acquisition, but I'm not complaining.)

    Rock (formerly Imperterritus VXt, Baja)
Sign In or Register to comment.