Enhanced Client Bugs?

HeskeyHeskey Posts: 2
Hi all,

I recently returned to UO and have been trying to get into the Enhanced Client. It's growing on me, but to make me very happy, I'd like to figure out why a couple of bugs exist, and how to fix them.

Rogue Hotbars

I have 2 hotbars that I keep minimized (one is the default one with the menu buttons). Every time I log into the game they've reset their positions into the middle of my game window (not stacked or in any logical place). I have tried moving them back, logging out via Esc > Log Out, and then reloaded the client only to find their positions have reset again. I have other hotbars and UI elements that don't do this.

Because they're in the middle of my game window, it's very annoying having to move them each time I log onto that character.

I've found that they don't like being "under" the paperdoll, even in the black space in the bottom left corner... but even when linked to another hotbar, they still "pop" about an inch away from it every time I log in despite them being logged.

I've temporarily fixed the issue by placing them elsewhere on the screen, but their placement isn't ideal.

Slow Chat Window

Sometimes the journal/chat window doesn't capture the last thing said, until something else is said - and sometimes this can affect the last 2-3 messages making it very difficult to refer to what I'm replying to once it's disappeared from overhead. It seems more likely to happen the longer I'm logged into the game, as when I log in it works as intended - but after a couple of scrolls up/down, mis-clicks, changing chat channel or just after a little bit of time, it starts to play up.

Other bugs in this post I can live with, but as a roleplayer this one is a deal breaker. I've since gone back to CC but I want to get to the bottom of this and move with the times.

Some Names / Approaching Names

All Names & Show Approaching Names only works some of the time. My macro is Alt + A and it'll show the names of some things and corpses on screen, but not others. A player ran past me before and it wouldn't show me his name, but when he came back 5 minutes later it did work. I was killing Earth Elementals and had 3 corpses around me. 2 more spawned - the names of the 3 corpses and 1 live EE would display, but not the other. It's just very random, with no logic.

I've noticed it corresponds with Show Approaching Names being temperamental, also - I run on screen and I'll see the names of a few things, but not others (problematic when approaching strong hostile mobs, or players) - it is these same mobiles that then also don't feature on All Names.

Disarm Bag?

Is there a way to set a disarm bag so my weapons aren't thrown into my main backpack?

Turn/Face, not move

Is there a way to face your character in another direction without having them take a step in that direction? Seems like this I can never stand up against a wall, etc - I always have to be 1 square away from it.

And I think that's about it. If I can get these sorted, I'll be a happy player.

All help appreciated, thanks in advance!

---------------

To head off some questions:

1.) I'm using the default UI, no mods.
2.) My All Names macro refers to the names above people's heads, not the ctrl+shift nameplaces. It's not set to repeat, either.

Comments

  • Arroth_ThaielArroth_Thaiel Posts: 242
    edited March 2

    @Heskey,

    I was messing around with the all names thing a bit on TestCenter. You are correct. There is some strange stuff going on there. I have never noticed it before. I could ride through Britain and only some of the NPC's overhead names would show. For the NPC's whose overhead names didn't show as I rode up, those names would never show no matter how many times I pushed the AllNames macro.


    There may be a solution. This is working for me.

    Main Menu>User Settings>Overhead Text

    Show Names: = Approaching

    Overhead Chat = Checked

    Overhead Chat Fade Delay: = 5 sec

    Or

    Show Names: = Approaching

    Overhead Chat = Unchecked


    If I have Overhead Chat checked and the delay is 10sec or more, it doesn't display all NPC names on approach, and those NPC's don't toggle with All Names. Looks like the EC is caching names or something. At least for me.

    Now that you have pointed this out, I'm going to have to fix this on all my toons.

    Just below Show Names is a Show Corpse Names checkbox. You might want to play around with the Overhead Text settings a bit and see if you can get something working for your setup. You might also want to look at Main Menu>User Settings>Moblies Bar and play around with the filters/delay. The number of mobiles bars the EC is pulling seems like it's tied into the show names thing.

    Anyway. Good Luck!

    EDIT: The turn/face thing really is about tap speed. Sorry. It's just harder to do in the EC. Think of it as the lightest, fastest, feather tap you can give the mouse key.

    -Arroth
  • Arroth_ThaielArroth_Thaiel Posts: 242

    So, I played around a bit more with All Names/Show Names and the Overhead Text/Mobiles Bar settings last night and this morning.

    I was wrong and I do not have a working fix. It works in the City of Britain (at least for me), but not out in the countryside. As soon as I left town and started to load various mobiles out in the woods around Britain the mobiles bars/show names/all names system just breaks.

    If I run towards a group of say six wolves, it will show names for maybe 5 of them, but will pull all 6 mobiles bars. If I wait for the overhead text to fade out and then push All Names, the 5 whose overhead names showed up originally will have those overhead names reappear, but the 6th (the one whose overhead name didn't show up originally) will not have an overhead name appear. No matter how many times I push All Names, that 6th ones overhead name won't appear.

    If I then run off screen, so that the 6th one is not on my screen, then run back to the group, the 6th ones overhead name will appear (along with the other 5). The 6th ones overhead name will now also appear every time I push All Names.

    I have tried turning off overhead text, changing the overhead text delay, cycling through the behaviors of the show names function, using various filters in the mobiles bars, changing the delays of the mobiles bars, legacy vs. enhanced targeting, and various object handle options.

    @Misk any ideas?

    -Arroth
  • HeskeyHeskey Posts: 2
    Annoying, isn't it? It means you can get jumped easily in Fel, or walk into a heavily hostile area whilst RPing.
  • TanagerTanager Posts: 210
    edited March 11
    First, welcome back to Sosaria! :)

    For the hot bars with ADHD, move the icons to another hot bar and then delete the 'broken' one. I cannot recall if you can delete the main one, but you can move those icons to a fresh bar and fill the default with icons that you use so that you don't want to minimize it. This fixes it for me.

    The chat window issue I have seen only when I have tried to modify it. Add time stamps, and it seems to glitch out the scroll bar. I have not found a way around this, sadly. Changing it back to default however will resolve the issue. (Might need to relog after changing them back.)

    EC has several hiccups regarding all names. I have not found a way around it, other than to note that the farther zoomed out I play the worse it seems to get. I really, REALLY wish there was an option for all names to show in journal as it does in CC.

    I'm afraid I have never delved into EC's bag sorting functions, so I have no info on that. However, you can set an equip macro to a specific item. When disarmed just hit the macro and voila, rearmed.

    The turn/face thing can be thwarted by going to User Settings > Options and making sure the 'auto navigate around objects' is NOT checked. I'd love to see a toggle for this that I can make into a macro.

    Hope this helps!
  • TimStTimSt Posts: 211
    Another Enhanced Client bug?  After I click a corpse's Loot All button my backpack starts acting odd until I log out.  One oddness is some items are no longer targetable and if I can target it and drag it may not drag at all but remain in the same spot as before.  Another oddness is new things added to the backpack may not show up visually.  If I hover my mouse pointer over the area I get the tool tip for the item. If I then target and drag the item it becomes visible.

    Any one else encounter this?
  • SyncrosSyncros Posts: 114
    Yea the incoming names is an ongoing issue for me as well.

    This bug annoys me, I made this macro for when I'm mining, use shovel, wait for target then last target.  Which works good but I have a use last object macro as well and it always stops working when I use my mining macro until I double click an item again.
  • DJAdDJAd Posts: 202
    I get the incoming names not showing and also one where my pet heath bars shows 0% until I click on it.
  • AlkaseltzerAlkaseltzer Posts: 5
    I'd like to see the scavenger agent to stick what it picks up into a certain bag in my backpack.
Sign In or Register to comment.